Automatic Sliding Door Cable Replacement on a 3rd Generation Honda Odyssey

I replaced the cable on the automatic sliding door on our 2009 Honda Odyssey EX-L and I thought I'd share what I learned. These instructions will apply to any 3rd generation Odyssey (2005, 2006, 2007, 2008, 2009, 2010) with automatic sliding doors (the EX-L and Touring).

I had previously done this on our 2002 Odyssey using a write up on the OdyClub forums. Much of it is the same, but there are very important things that are different. This is not a full write up. I'm only writing about what is different with the 3rd gen. There is a video I've posted at the bottom of this, but make sure you read all of this too.

First off: this job is not pleasant. If you can find the entire motor assembly for a price you’re willing to pay, go for it. The entire assembly is definitely easier to remove than it was in the 2nd gen.

Parts

All the parts are the same, except for the cable. The green cable from Home Depot won’t work. The OEM cable is 1/16”, just the same as the green cable. But the OEM cable has a very, very thin coating. The green stuff has a thicker coating that brings the outside diameter of the cable to 3/32. That’s too big to fit in the motor used in the 3rd gens.

I ended up using 1/16” uncoated galvanized aircraft cable. Here in Canada, it seems to be harder to find this stuff. My father-in-law ended up calling around for me and got some from an aircraft mechanic. It cost more than it would elsewhere ($1/ft), but this stuff is tough. I couldn’t cut it at all with wire cutters. I ended up using my angle grinder to cut it. You can find 1/16” galvanized cable at Home Depot, though the quality may not be the same.

Being uncoated, there is a worry of it rusting out if the galvanization wears off. My OEM cable rusted out where the coating was damaged, which caused it to break. That’s one factor of why I’m more comfortable getting it from who I did: the galvanization is probably better and less likely to wear off as quickly (or at all). Time will tell.

Some Home Depot stores in the US stock 1/16” stainless steel wire rope. That would work too. Although one of the aircraft guys my father-in-law talked to said that the stainless stuff is weaker and also doesn’t like to be constantly bent. Your mileage may vary.

The length of the cable is very important to get right. You don’t have much leeway. For the driver’s side, the cable going toward the front of the van is about 66”. The cable going around the back is about 62”. I did not replace the passenger side, so I can’t tell you those lengths. Cut it a half inch longer just in case. You can always cut some off later, but you don’t have too many options to length is. I did have to lengthen mine a bit. I added about an inch on the back cable. I put a short length in the roller, and used one of the stops from the ferrule and stop set to attach it to the cable going to the motor. You can only put on a couple inches in that spot, so it’s much better to just get the cable length right the first time.

Opening the motor

The driver’s side motor is so much easier to get to. The passenger side is in an awkward spot, so you will have to unmount it to work on it. The motor has a bunch of screws on the outside of it. Those can all come off. Here is a picture with the cover removed.

Door motor


A 10mm bolt and washer releases the pulley, and everything comes out. The white stoppers just clip in, so you can pull those right off. You may need to release the bottom clips of the white stoppers and push them up, then pull them out.

Putting it back together

I could not get the wire to feed through without taking off the rest of the assembly (where it feeds to the outside). There are 3 10mm bolts at the back, 4 in the front. Take those off, and pull off the rubber covers. Feed the wire from the inside out: feed it through the tube, so it eventually comes out at the roller. I found that it would stop right where it met the roller. The end of my cable was frayed a bit, so I think that’s why. I was able to use some pliers to push it through with more force than I could by hand.

Put the rubber covers back on and reattach. At this point you have one end of the cables at the motor and the other end outside.

I found that I had to feed the cable into the motor pulley before crimping the stop on it. But before that, feed the spring and white stopper over the cable. The springs have a straight piece at the one end, which must go toward the inside of the motor. Make sure you have the white stopper with the clip toward the bottom. After those are over the cable, you can feed the cable into the pulley. The cable coming into the left of the motor goes into the back of the pulley. The cable coming into the right of the motor goes into the front of the pulley (regardless of driver or passenger side). Feed the wire straight through to the other side, then crimp on the stopper. You can then pull it back and ensure it doesn’t come back out.

Once both cables are attached, go outside and attach the roller (you could do this first if you want). The instructions for this are the same as the 2nd gen. Although I found that the cable was slipping out of those lugs. The screw was bottoming out before it was quite tight enough (although it was quite tight). So I ended up putting a small second piece of cable in the lug with the main cable so I could screw it down harder. Attach the door at this point if you want.

Back inside, roll the cables around the pulley as much as you can and push it into the housing. The gear the pulley sits on moves quite freely, so you will have a hard time lining it up right.

Clip in the white stoppers, and push the springs into place. This is a pain. The straight piece coming off the springs feed into a hole on either side. Use small pliers and a light so you can see the hole. Once those are in the hole, make sure you don’t pull the wire outward, or you’ll pull those springs out. It’s annoying when that happens.

Put the washer and nut back over the pulley. Make sure the white stoppers are pushed all the way down so that they clip in.

By this point you would have noticed that there are also white clips around the pipe the cable feeds through that hold it to the body of the van. Put those back on. Those can be opened up with some effort if need be.

It’s wise to test things before you put everything back together, but if you test, make sure you either hold down the spring on the right with a finger, or put the cover on with at least one screw. The right spring can pop out otherwise.


If you have any questions, ask me in the comments here, on the video, or in the thread over at the OdyClub forums where I first posted this.

Here's the video:

No comments:

Post a Comment